Zurzeit sind 750 Mitglieder online.
Zurzeit sind 750 Mitglieder online.
Fragen zum Thema Berichte, Personalisierung, Dashboards, Scheduling, Echtzeit. Fragen zu Zielgruppen, Interessen, Demographie, Technologie, Provider? Fragen zum Thema Verhalten, Content, Pfade, Seiten, Ereignisse, Suche oder Testing? Kontaktiere uns hier.
Anleitung
favorite_border
Antworten

Internet Explorer wirft keine PageViews ab

[ Bearbeitet ]
Top Beitragender
# 1
Top Beitragender

Hallo,

 

in einem meiner Konten habe ich ein faszinierendes Problem: Bei manchen Kombinationen aus Betriebsversion & Browser (Versionen) erfasst Analytics fast keine PageViews (reguläre ja, angepasst nicht). Interessant dabei ist, dass es nicht so ist, dass gar keine Erfasst werden, nur viel zu wenige bzw. nicht alle. Hier ein Beispiel:

Bildschirmfoto 2015-04-21 um 12.06.37.png

 

Das Goal 1 wird via virtuellem Pageview getrackt, die Transactions werden nur 1 mal pro Session abgeworfen und beides soll theoretisch das Selbe messen. Da es unterschiedlich eingebaut ist, ist eine kleine Abweichung akzeptabel, jedoch nicht in diesem Ausmaß. Das Problem besteht erst seit der Umstellung auf Universal Analytics, zuvor gab es nur eine geringe Abweichung. Daher kann ich sagen, dass der IE hier definitiv zu wenig trackt, aber auch der Firefox nicht genau ist. Es betrifft alle Browser Chrome, Safari....

 

Die IT sagt es liegt an Analytics, es ist alles richtig eingebaut etc. In Test haben wir auch immer das Pixel im Firebug gehabt, nur warum kommt es nicht in Analytics an?

 

Irgendwelche Ideen?

 

Gruß

Maren

Find me on: LinkedIn | Xing | maren-ockels.com
3 Expertenantwort(en)verified_user

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 2
Top Beitragender
Hallo Maren,

wie wird der virtuelle Pageview generiert? Durch den Klick auf einen Link?
Evtl. ist beim IE11 das Zeitfenster für die Ausführung von JavaScript-Code vor dem Seitenwechsel zu kurz. D.h. die Ausführung wird abgebrochen, wenn die neue Seite dargestellt wird und das Tracking funktioniert deshalb nur bei sehr langsamen Verbindungen.

Hier eine saubere Lösung für dieses Problem (auch wenn hier mit Events statt Pageview gearbeitet wird):
https://support.google.com/analytics/answer/1136920?hl=de

Wenn's das nicht war, schreib mal, wie und wann der virtuelle Pageview erzeugt wird.

Viel Erfolg

Holger

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 3
Top Beitragender
Hallo Holger,

vielen Dank.
Nein, der Pageview wird klassisch als Pageview beim Aufruf auf die Seite aufgerufen/abgefeuert. Es sollte also eigentlich kein Zeitproblem geben.

Grüße
Maren
Find me on: LinkedIn | Xing | maren-ockels.com

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 4
Top Beitragender
Und warum dann "virtueller Pageview"?

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 5
Top Beitragender
ah, ja, sehe ich, dass ich das falsch benannt habe. Wollte mit ausdrücken, dass wir den PageView überschreiben und nicht den der Seite nehmen.
Find me on: LinkedIn | Xing | maren-ockels.com

Betreff: Internet Explorer wirft keine PageViews ab

[ Bearbeitet ]
Top Beitragender
# 6
Top Beitragender

Hallo Maren,

 

interessantes Problem ...

 

Ich hab das mal in einem vergleichbaren Konto bei mir nachgestellt - sehe an dieser Stelle keinerlei Auffälligkeiten: Win-7-Kauf-Zielerreichungen von IE 11.0 und Firefox 37.0 in der gleichen Größenordnung. Auch die Abweichung von Transactions und entsprechenden Goal Completions unterscheiden sich maximal um ein paar Prozent.

 

  • Schalte mal in deiner Flat Table noch "Device Category" als 5. Dimension dazu und schau, ob das evtl. etwas mit Mobile zu tun hat
  • Mach dir Segmente mit diesen beiden Browserversionen und schau in den Seiten-Reports und den Trichteranalysen an, ob das Problem auf der ganzen Website oder erst im Shop auftritt
  • Überprüfe, ob die Code-Auslieferung des Analytics-Codes (falls hier kein Tag-Manager benutzt wird) im HTML-Code evtl. zusammen mit CSS-Weichen für den IE ausgeliefert wird

Viele Grüße, Christoph

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 7
Top Beitragender
Hallo Christoph,

vielen Dank für Deine Rückmeldung.
Was ich vielleicht noch ergänzen sollte: der Funnel ist etwas kniffelig eingebunden: ein iFrame auf einer Subdomain, wobei die umgebene Seite die "normale" Seite ist. Sowohl auf der umgebenen Seite als auch auf dem iFrame ist Analytics. Im iFrame wird der PageView abgeworfen.

Device Category: nein, mobile hat hier keinen wichtigen Einfluss.
Das Problem tritt erst im Funnel auf. Ich vermute daher ein Problem mit dem iFrame, aber sicher bin ich nicht.

Das mit den möglichen CSS-Weichen habe ich an die IT weitergeleitet.

Grüße
Maren
Find me on: LinkedIn | Xing | maren-ockels.com

Betreff: Internet Explorer wirft keine PageViews ab

Top Beitragender
# 8
Top Beitragender

Wenn die Daten im IFrame z.T. korrekt getrackt werden, ist das schon mal kein IFrame-Problem an sich. 

 

Sub-Domain-Tracking sollte auch kein Problem sein, wenn ihr Universal Analytics verwendet und keine einzelnen Domains im Tracking-Code definiert habt.

 

Das muss dann, wi du sagst, am ehesten an einzelnen Seiten im Warenkorb liegen, dass da der IE bzgl. Tracking irgendwie anders behandelt wird.

 

Auf der anderen Seite solltest du auch nochmals die Definition von Ziel 1 überprüfen. Gibt es bzgl. der Danke-Seite eine Abhängigkeit vom IE? Der 20%-Unterschied zwischen Transaktionen und Zielerreichung ist auch deutlich zu groß. Wird das an derselben Stelle gemessen? Gibt es eine Abhängigkeit vom betrachteten Zeitraum? Bestellen wirklich die Hälfte eurer Käufer mehrmals pro Sitzung?